Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях
Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Распространенный вопрос по Excel «Как записывать несколько условий в одной формуле?». Особенно часто применяется два и более условий при использовании функции ЕСЛИ. Сделать несколько условий в формуле ЕСЛИ довольно просто, главное знать основные принципы. Их и обсуждаем ниже.

На мой взгляд, показательно рассмотреть пример с решением системы условий. Такие задания часто задают в институтах, на парах по Excel.

Например, есть вот такая, довольно нагроможденная формула:

vAkJzQfNZOo

Разберем на примере, как перенести ее в Excel

Содержание

Как записать несколько условий в формуле ЕСЛИ?

Понятно, что эта формула будет состоять из 3 частей, как минимум:

Несколько Если

=SIN(B1)^2
=COS(B1)
=EXP(1/B1)

Об экспоненте можно подробно прочитать здесь.

Но как записать несколько этих функций в одну, еще и по условию? Для того чтобы разобраться, подробно посмотрим на функцию ЕСЛИ.

Ее состав следующий:

=ЕСЛИ(Условие;если условие = ДА (ИСТИНА);если условие = НЕТ (ЛОЖЬ))

Т.е. если мы запишем простую формулу, что мы получим в итоге в ячейке B2?

Несколько Если2

Верно — отобразиться 100. Если же в А1 будет стоять любое другое значение кроме 1, то в B2 отобразится бы 0.

Вернемся к нашей системе условий. Теперь нам надо понимать как записать сразу два условия до первой точки с запятой. У нас в B1 пусто, а значит = 0, и только при выполнении обоих условий А1=1 и B1=0 (знак ) значение формулы будет равно 100.

Несколько Если3

Особо разберем между скобками

Оператор И он же  означает, что должно выполняться оба условия одновременно, А1=1 и B1=0.

Если между скобками поставить + (или), то достаточно будет одного из условий. Например только если А1=1, то уже будет отображаться 100.

Мы готовы к написанию формулы, будем это делать по частям

Запишем первое условие

=ЕСЛИ((B1>-2)(B1<9);SIN(B1)^2);

Если условие выполняется, то выполняется первая формула с синусом
Если нет, второе условие

=ЕСЛИ((B1>-2)(B1<9);SIN(B1)^2;ЕСЛИ((B1>=9)(B1<=19);COS(B1)

Во всех же остальных случаях будет выполнятся формула =EXP(1/B1)
Итого получается:

=ЕСЛИ((B1>-2)(B1<9);SIN(B1)^2;ЕСЛИ((B1>=9)(B1<=19);COS(B1);EXP(1/B1)))

Запись нескольких формул в одной

Если в ячейки B1 будет текст, то формула выдаст ошибку. Поэтому я часто применяю формулу =ЕСЛИОШИБКА().

Представим что вся наша формула из предыдущего пункта это один условный аргумент А

Тогда =ЕСЛИОШИБКА(А;»»)

Или для нашего примера

=ЕСЛИОШИБКА(ЕСЛИ((B1>-2)(B1<9);SIN(B1)^2;ЕСЛИ((B1>=9)(B1<=19);COS(B1);EXP(1/B1)));"")

Пример можно скачать здесь

Как красиво записать несколько формул

Иногда бывает более 20 если, тут легко и запутаться… Поэтому существует удобный способ, как записать много формул в одну и удобно отобразить ее в несколько строк. И по прошествии времени разбираться в этой формуле будет легче. С описанием этой отличной возможности мы написали целую статью. Подробно можно прочитать здесь

Выглядеть это будет примерно так:

FormyluStolbec

Удачи!

 

Поделитесь нашей статьей в ваших соцсетях:

Похожие статьи

(Visited 2 262 times, 11 visits today)



Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях

Как самой сделать макияж в домашних условиях